October 20, 2007

Slow internet connection in Ubuntu 7.10 Gutsy Gibbon

I finally managed to install Ubuntu 7.10, Gutsy Gibbon. As I wrote in my earlier post, it was not such a straightforward experience.

Tweaking firefox is usually the first thing I do after installing any operating system. The very first thing I do is to set home page to www.google.ca .

I was shocked to see that the main google page took many seconds to come! After trying few other addresses, I realized that there is something wrong.

I well remember that in Ubuntu 6.10 I had the very same problem. This was totally gone in Ubuntu 7.04 and now in 7.10 it is back again.

This is a partial solution:

In firefox, type:

find this:

and change its value to "true"

There you go! It fairly fixes the problem in firefox but the connection is still painfully slow and with serveral seconds delay in anywhere else (for instance when you want to update your repositories in synaptic).

Ubuntu 7.10 Gutsy Gibbon feels more like Windows, painfully frustrating.

October 19, 2007

First experience with Ubuntu 7.10 (Gutsy Gibbon): Disasterous!

I have been impatiently waiting for the release of Ubuntu 7.10, Gutsy Gibbon.

I finally managed to download the DVD iso image, burnt it into a DVD and just waited for the right moment. Late in the night, I grabbed my coffee, dimmed the lights, and fired up my computer with the DVD. For me, the most exciting aspect of Ubuntu is its visual appeal. Very recently, with the introdoction of Compiz Fusion, this appeal just become something hot.

When the computer was starting up with the live DVD, something badly went wrong. The right graphic driver could not be found and instead I was forced to opt for basic one. It had never happened to me with any version of Ubuntu and with my current hardware configuration. My graphic card is an integrated Intel GMA 965, X3000. It has been serving Ubuntu 7.04, Feisty Fawn without any problem.

I was hopping that with the installation of Gutsy Gibbon to the hard drive, it will resolve the problem. I was so wrong.

When installation finished and system restarted, I was shocked to see a resolution of no more than 800x600 on a wide screen monitor with native resolution of 1440x900.
I played with different settings. after a while I managed to get the resolution right. but to my surprise, visual effects (Compiz) could not be started, a sign of wrong graphic driver.

Finally, I gave up with a bitter sense of disappointment. I may find a solution here and there. I will definitely give it a try. But I will never forget that Gutsy Gibbon was not what it meant to be in the first try. Feisty Fwan! I have so missed you!

When I edited menu.lst, to set Windows Vista as default operating system again, and restarted back to Vista, for the first time, I felt happy going back to Windows.

[Update: it is known that Intel 965 graphic chipset is in compiz blacklist. You can force compiz to skip checking and everything goes back to normal.

to do so, in terminal make sure you are in your home directory then type:

sudo gedit .config/compiz/compiz-manager

and add this line:


now try compiz again.]